Динамический список в статический


Доброго времени суток, коллеги. Здесь я публикую всякие полезные скриптики.

Я ни в коем случае не претендую на звание ГУРУ. То, что я здесь излагаю является не более, чем записной книжкой и пособием по настройке оборудования. Если это послужит кому-нибудь подспорьем, то добро пожаловать

Итак, начинаем

RouterOS в Mikrotik не запоминает динамические элементы списков адресов и в случае перезагрузки или пропажи питания, в списках останутся только статичные элементы. Если у вас есть правило, отлавливающее спамеров или сканеров портов и банящее их IP адреса , то это не очень удобно. База адресов, собранная за месяцы непрерывной работы шлюза не сохранится :-(

Я запускаю раз в сутки шедулером простенький скриптик, который и преобразует эти списки в статические (не забудьте заменить в двух местах название списка, который у меня зовётся Black-List-WAN):

:local dyn Black-List-WAN;
:foreach i in=[/ip firewall address-list find (dynamic=yes)&&(list=$dyn)] do={
:local a [/ip firewall address-list get value-name=address $i]                  
/ip firewall address-list remove $i
/ip firewall address-list add address=$a list=Black-List-WAN}

Следующим шаком добавляем это в шедулер и вуаля

Надеюсь, что у вас всё получилось.
Если же нет, то добро пожаловать в раздел КОНТАКТЫ

IT-admins

IT-admins

8.00 - 17.00

☎ +7 (905) 480-54-70
☎ +7 (917) 199-81-13
info@it-admins.ru


IT-admins © 2020